Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Do you have any idea what the problem is?
Note: Server installed in December 2018. Everything worked. In January there was an upgrade on server side. Last days I tried to run the client, and got this error.

Server: Hashtopolis: 0.10.1, OS Ubuntu 64bit
Client: OS kali, 32 bit

Command was on client side:
Starting client 's3-python-0.4.0'...
Please enter the url to the API of your Hashtopolis installation:
No token found! Please enter a voucher to register your agent:
Successfully registered!
Collecting agent data...
Login successful!
Hashtopolis Server version: 0.10.1 ()
Client is up-to-date!
Got task with id: 4
Downloading: [==================================================]
sh: 1: ./7zr: Exec format error
Traceback (most recent call last):
  File "/usr/lib/python3.7/", line 193, in _run_module_as_main
    "__main__", mod_spec)
  File "/usr/lib/python3.7/", line 85, in _run_code
    exec(code, run_globals)
  File "", line 338, in <module>
  File "", line 174, in loop
  File "", line 164, in check_version
FileNotFoundError: [Errno 2] No such file or directory: 'crackers/temp'

Tested OS 64bit windows. Not working.
python psutil and requests installed:
pip3 install requests psutil
Requirement already satisfied: psutil in /usr/lib/python3/dist-packages (5.5.1)
Requirement already satisfied: requests in /usr/lib/python3/dist-packages (2.21.0)
The problem is this:
sh: 1: ./7zr: Exec format error

This means the 7zr binary is present but for whatever reason it can't be executed.
I'm pretty sure the 7zr binary distributed with hashtopolis is a 64-bit binary. And since you're running a 32-bit Linux that won't work.
To be sure you can use the file command. It's output should look like this:

$ file 7zr
7zr: ELF 64-bit LSB executable, x86-64, version 1 (GNU/Linux), statically linked, no section header

The best advice I can give you is to use a 64-bit system not only because it's 2019 but the upcoming hashcat 6.0 won't have 32-bit binaries anymore (finally!)

Forum Jump:

Users browsing this thread: 1 Guest(s)